Skip to page content

AEGLIX MIND

Intelligence for Africa and the Gulf

AEGLIX vulnerability intelligence

CVE-2019-11580

CRITICAL · CVSS 9.8 · Analyzed

Published: 2019-06-03 · Updated: 2026-06-17 · Source: NVD

Vulnerability overview

Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send unauthenticated or authenticated requests to a Crowd or Crowd Data Center instance can exploit this vulnerability to install arbitrary plugins, which permits remote code execution on systems running a vulnerable version of Crowd or Crowd Data Center. All versions of Crowd from version 2.1.0 before 3.0.5 (the fixed version for 3.0.x), from version 3.1.0 before 3.1.6 (the fixed version for 3.1.x), from version 3.2.0 before 3.2.8 (the fixed version for 3.2.x), from version 3.3.0 before 3.3.5 (the fixed version for 3.3.x), and from version 3.4.0 before 3.4.4 (the fixed version for 3.4.x) are affected by this vulnerability.

Severity and scoring

CVSS score
9.8 · CRITICAL
CVSS version
3.1
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
NVD-CWE-noinfo

CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.

Known exploitation and remediation

Listed in CISA’s Known Exploited Vulnerabilities catalog.

Affected product
Atlassian · Crowd and Crowd Data Center
Added to catalog
2021-11-03
Required action
Apply updates per vendor instructions.
CISA remediation due date
2022-05-03

CISA deadlines apply to the organizations covered by its directives. Confirm your own remediation requirements.

Verify affected versions and patch availability in the vendor advisory before making changes.

Affected products and versions

  • cpe:2.3:a:atlassian:crowd:*:*:*:*:*:*:*:*

    From (inclusive): 2.1.0

    Before (exclusive): 3.0.5

  • cpe:2.3:a:atlassian:crowd:*:*:*:*:*:*:*:*

    From (inclusive): 3.1.0

    Before (exclusive): 3.1.6

  • cpe:2.3:a:atlassian:crowd:*:*:*:*:*:*:*:*

    From (inclusive): 3.2.0

    Before (exclusive): 3.2.8

  • cpe:2.3:a:atlassian:crowd:*:*:*:*:*:*:*:*

    From (inclusive): 3.3.0

    Before (exclusive): 3.3.5

  • cpe:2.3:a:atlassian:crowd:*:*:*:*:*:*:*:*

    From (inclusive): 3.4.0

    Before (exclusive): 3.4.4

These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.

Advisories and references

Explore official sources

Read the official NVD record ↗

Explore the CISA catalog ↗

Back to CVE intelligence