Skip to page content

AEGLIX MIND

Intelligence for Africa and the Gulf

AEGLIX vulnerability intelligence

CVE-2019-1543

HIGH · CVSS 7.4 · Modified

Published: 2019-03-06 · Updated: 2026-11-02 · Source: NVD

Stored catalog record

Source record retrieved 2026-11-02T19:30:14.594158+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.

Continue your research

Connect this record to stored reporting, reviewed campaign mentions and source-domain investigation. These are research leads, not inferred attack relationships.

Open CVE research in Investigate · Find Arsenal listings referencing this CVE

Vulnerability overview

ChaCha20-Poly1305 is an AEAD cipher, and requires a unique nonce input for every encryption operation. RFC 7539 specifies that the nonce value (IV) should be 96 bits (12 bytes). OpenSSL allows a variable nonce length and front pads the nonce with 0 bytes if it is less than 12 bytes. However it also incorrectly allows a nonce to be set of up to 16 bytes. In this case only the last 12 bytes are significant and any additional leading bytes are ignored. It is a requirement of using this cipher that nonce values are unique. Messages encrypted using a reused nonce value are susceptible to serious confidentiality and integrity attacks. If an application changes the default nonce length to be longer than 12 bytes and then makes a change to the leading bytes of the nonce expecting the new value to be a new unique nonce then such an application could inadvertently encrypt messages with a reused nonce. Additionally the ignored bytes in a long nonce are not covered by the integrity guarantee of this cipher. Any application that relies on the integrity of these ignored leading bytes of a long nonce may be further affected. Any OpenSSL internal use of this cipher, including in SSL/TLS, is safe because no such use sets such a long nonce value. However user applications that use this cipher directly and set a non-default nonce length to be longer than 12 bytes may be vulnerable. OpenSSL versions 1.1.1 and 1.1.0 are affected by this issue. Due to the limited scope of affected deployments this has been assessed as low severity and therefore we are not creating new releases at this time. Fixed in OpenSSL 1.1.1c (Affected 1.1.1-1.1.1b). Fixed in OpenSSL 1.1.0k (Affected 1.1.0-1.1.0j).

Patch review priority

Assess exposure and vendor guidance

  • No higher-priority signal is available in the current stored evidence.
  • Fresh EPSS data is unavailable; missing values are not zero.

EPSS unavailable; no zero score is assumed.

EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗

Severity and scoring

CVSS score
7.4 · HIGH
CVSS version
3.0
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-327, CWE-330

CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.

Known exploitation and remediation

Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.

Verify affected versions and patch availability in the vendor advisory before making changes.

Affected products and versions

  • cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:*

    From (inclusive): 1.1.0

    Through (inclusive): 1.1.0j

  • cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:*

    From (inclusive): 1.1.1

    Through (inclusive): 1.1.1b

These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.

Advisories and references

Explore official sources

Read the official NVD record ↗

Explore the CISA catalog ↗

Back to CVE intelligence