Skip to page content

AEGLIX MIND

Intelligence for Africa and the Gulf

AEGLIX vulnerability intelligence

CVE-2019-3398

HIGH · CVSS 8.8 · Analyzed

Published: 2019-04-18 · Updated: 2026-06-17 · Source: NVD

Continue your research

Connect this record to stored reporting, reviewed campaign mentions and source-domain investigation. These are research leads, not inferred attack relationships.

Open CVE research in Investigate · Find Arsenal listings referencing this CVE

Vulnerability overview

Confluence Server and Data Center had a path traversal vulnerability in the downloadallattachments resource. A remote attacker who has permission to add attachments to pages and / or blogs or to create a new space or a personal space or who has 'Admin' permissions for a space can exploit this path traversal vulnerability to write files to arbitrary locations which can lead to remote code execution on systems that run a vulnerable version of Confluence Server or Data Center. All versions of Confluence Server from 2.0.0 before 6.6.13 (the fixed version for 6.6.x), from 6.7.0 before 6.12.4 (the fixed version for 6.12.x), from 6.13.0 before 6.13.4 (the fixed version for 6.13.x), from 6.14.0 before 6.14.3 (the fixed version for 6.14.x), and from 6.15.0 before 6.15.2 are affected by this vulnerability.

Severity and scoring

CVSS score
8.8 · HIGH
CVSS version
3.1
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-22

CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.

Known exploitation and remediation

Listed in CISA’s Known Exploited Vulnerabilities catalog.

Affected product
Atlassian · Confluence Server and Data Center
Added to catalog
2021-11-03
Required action
Apply updates per vendor instructions.
CISA remediation due date
2022-05-03

CISA deadlines apply to the organizations covered by its directives. Confirm your own remediation requirements.

Verify affected versions and patch availability in the vendor advisory before making changes.

Affected products and versions

  • cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:*

    From (inclusive): 2.0

    Before (exclusive): 6.6.13

  • cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:*

    From (inclusive): 6.7.0

    Before (exclusive): 6.12.4

  • cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:*

    From (inclusive): 6.13.0

    Before (exclusive): 6.13.4

  • cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:*

    From (inclusive): 6.14.0

    Before (exclusive): 6.14.3

  • cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:*

    From (inclusive): 6.15.0

    Before (exclusive): 6.15.2

These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.

Advisories and references

Explore official sources

Read the official NVD record ↗

Explore the CISA catalog ↗

Back to CVE intelligence