Skip to page content

AEGLIX MIND

Intelligence for Africa and the Gulf

AEGLIX vulnerability intelligence

CVE-2021-21353

MEDIUM · CVSS 6.8 · Analyzed

Published: 2021-03-03 · Updated: 2026-11-02 · Source: NVD

Stored catalog record

Source record retrieved 2026-11-02T19:30:18.219907+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.

Continue your research

Connect this record to stored reporting, reviewed campaign mentions and source-domain investigation. These are research leads, not inferred attack relationships.

Open CVE research in Investigate · Find Arsenal listings referencing this CVE

Vulnerability overview

Pug is an npm package which is a high-performance template engine. In pug before version 3.0.1, if a remote attacker was able to control the `pretty` option of the pug compiler, e.g. if you spread a user provided object such as the query parameters of a request into the pug template inputs, it was possible for them to achieve remote code execution on the node.js backend. This is fixed in version 3.0.1. This advisory applies to multiple pug packages including "pug", "pug-code-gen". pug-code-gen has a backported fix at version 2.0.3. This advisory is not exploitable if there is no way for un-trusted input to be passed to pug as the `pretty` option, e.g. if you compile templates in advance before applying user input to them, you do not need to upgrade.

Patch review priority

Assess exposure and vendor guidance

  • No higher-priority signal is available in the current stored evidence.
  • Fresh EPSS data is unavailable; missing values are not zero.

EPSS unavailable; no zero score is assumed.

EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗

Severity and scoring

CVSS score
6.8 · MEDIUM
CVSS version
3.1
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:N
Weaknesses
CWE-74, CWE-94

CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.

Known exploitation and remediation

Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.

Verify affected versions and patch availability in the vendor advisory before making changes.

Affected products and versions

  • cpe:2.3:a:pugjs:pug:*:*:*:*:*:node.js:*:*

    Before (exclusive): 3.0.1

  • cpe:2.3:a:pugjs:pug-code-gen:*:*:*:*:*:node.js:*:*

    Before (exclusive): 2.0.3

  • cpe:2.3:a:pugjs:pug-code-gen:*:*:*:*:*:node.js:*:*

    From (inclusive): 3.0.0

    Before (exclusive): 3.0.2

These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.

Advisories and references

Explore official sources

Read the official NVD record ↗

Explore the CISA catalog ↗

Back to CVE intelligence