AEGLIX vulnerability intelligence
CVE-2023-32315
HIGH · CVSS 8.6 · Analyzed
Published: 2023-05-26 · Updated: 2026-06-17 · Source: NVD
Vulnerability overview
Openfire is an XMPP server licensed under the Open Source Apache License. Openfire's administrative console, a web-based application, was found to be vulnerable to a path traversal attack via the setup environment. This permitted an unauthenticated user to use the unauthenticated Openfire Setup Environment in an already configured Openfire environment to access restricted pages in the Openfire Admin Console reserved for administrative users. This vulnerability affects all versions of Openfire that have been released since April 2015, starting with version 3.10.0. The problem has been patched in Openfire release 4.7.5 and 4.6.8, and further improvements will be included in the yet-to-be released first version on the 4.8 branch (which is expected to be version 4.8.0). Users are advised to upgrade. If an Openfire upgrade isn’t available for a specific release, or isn’t quickly actionable, users may see the linked github advisory (GHSA-gw42-f939-fhvm) for mitigation advice.
Severity and scoring
- CVSS score
- 8.6 · HIGH
- CVSS version
- 3.1
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
- Weaknesses
- CWE-22
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Listed in CISA’s Known Exploited Vulnerabilities catalog.
- Affected product
- Ignite Realtime · Openfire
- Added to catalog
- 2023-08-24
- Required action
- Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
- CISA remediation due date
- 2023-09-14
CISA deadlines apply to the organizations covered by its directives. Confirm your own remediation requirements.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
cpe:2.3:a:igniterealtime:openfire:*:*:*:*:*:*:*:*
From (inclusive): 3.10.0
Before (exclusive): 4.6.8
cpe:2.3:a:igniterealtime:openfire:*:*:*:*:*:*:*:*
From (inclusive): 4.7.0
Before (exclusive): 4.7.5
These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.
Advisories and references
- http://packetstormsecurity.com/files/173607/Openfire-Authentication-Bypass-Remote-Code-Execution.html
Exploit · Third Party Advisory · VDB Entry
- https://github.com/igniterealtime/Openfire/security/advisories/GHSA-gw42-f939-fhvm
Exploit · Mitigation · Patch · Vendor Advisory
- http://packetstormsecurity.com/files/173607/Openfire-Authentication-Bypass-Remote-Code-Execution.html
Exploit · Third Party Advisory · VDB Entry
- https://github.com/igniterealtime/Openfire/security/advisories/GHSA-gw42-f939-fhvm
Exploit · Mitigation · Patch · Vendor Advisory
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-32315
US Government Resource