AEGLIX vulnerability intelligence
CVE-2026-109383
HIGH · CVSS 7.4 · Analyzed
Published: 2026-10-15 · Updated: 2026-10-19 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:22:45.721456+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
undici is an HTTP client library for Node.js. In versions 4.0.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its Agent dispatcher passes its constructor options through a JSON-based deep clone before forwarding them to each per-origin pool, and because JSON cannot represent functions, a caller-supplied tls option containing a checkServerIdentity callback is silently dropped before it reaches the TLS layer. As a result, a TLS peer whose certificate a custom checkServerIdentity was written to reject, but which passes Node's default hostname and chain checks, is silently accepted. Because Agent is the default dispatcher behind request, fetch, and setGlobalDispatcher, this affects the path most applications use, and EnvHttpProxyAgent is affected on its direct and no-proxy routes as well, while only applications that pass a function-valued tls option such as a custom checkServerIdentity for certificate or public-key pinning are at risk. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which preserve the tls option outside the JSON clone so custom verification callbacks are forwarded unchanged, and users should upgrade to one of those versions or later. As a workaround, pass the TLS options through connect instead of tls, or for proxied destinations use requestTls and proxyTls.
Patch review priority
Assess exposure and vendor guidance
- No higher-priority signal is available in the current stored evidence.
FIRST EPSS: 0.18% · percentile 7.9 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 7.4 · HIGH
- CVSS version
- 3.1
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-295
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:*
From (inclusive): 4.0.0
Before (exclusive): 6.29.1
cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:*
From (inclusive): 7.0.0
Before (exclusive): 7.30.1
cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:*
From (inclusive): 8.0.0
Before (exclusive): 8.12.2
These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.
Advisories and references
- https://cna.openjsf.org/security-advisories.html
Vendor Advisory
- https://github.com/nodejs/undici/security/advisories/GHSA-2m5v-pch6-74hx
Mitigation · Vendor Advisory