AEGLIX vulnerability intelligence
CVE-2026-109414
MEDIUM · CVSS 6.5 · Deferred
Published: 2026-10-16 · Updated: 2026-10-16 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:22:56.914446+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
The Vitepos – Point of Sale (POS) for WooCommerce plugin for WordPress is vulnerable to blind SQL Injection via the 'src_by[].val.start / src_by[].val.end (operator 'bt')' parameter in all versions up to, and including, 3.6.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with vendor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This is an incomplete fix for a previously patched SQL injection (version 3.6.0), which addressed only the gt/lt/le/ge operators while leaving the 'bt' (BETWEEN) operator branch unpatched.
Patch review priority
Assess exposure and vendor guidance
- No higher-priority signal is available in the current stored evidence.
FIRST EPSS: 0.27% · percentile 18.7 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 6.5 · MEDIUM
- CVSS version
- 3.1
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-89
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
NVD has not supplied affected-version configurations for this record. Check the vendor references below.
Advisories and references
- https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.6.1/vendor/appsbd-wp/appsbd-lite/appsbd_lite/v6/core/class-basemodel.php#L2925
- https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.6.1/vitepos_lite/api/v1/class-pos-outlet-api.php#L66
- https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.6.1/vitepos_lite/api/v1/class-pos-purchase-api.php#L71
- https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.6.1/vitepos_lite/api/v1/class-pos-vendor-api.php#L74
- https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.6.1/vitepos_lite/libs/class-api-base.php#L467
- https://plugins.trac.wordpress.org/changeset?reponame=&old=3732582%40vitepos-lite&new=3732582%40vitepos-lite
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bb6c82b0-d9c7-4777-829d-885f24da4f36?source=cve