AEGLIX vulnerability intelligence
CVE-2026-109869
HIGH · CVSS 7.5 · Analyzed
Published: 2026-10-15 · Updated: 2026-10-19 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:22:45.820459+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
undici is an HTTP client library for Node.js. In versions 6.23.0 through 6.29.0, 7.18.0 through 7.30.0, and 8.0.0 through 8.12.1, its fetch() implementation crashes the Node.js process when a malicious server returns a response with more than five content codings and closes the connection before sending the body. undici rejects such responses because of a content-encoding limit, but it created the internal response stream before that check and returned without attaching an error listener or aborting the request, so the early close surfaces a content-length mismatch on the orphaned stream, which Node.js treats as an unhandled error and terminates the process. A remote, unauthenticated server can trigger this with a single response, even when the application correctly catches the fetch() rejection, resulting in a denial of service. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, and users should upgrade to one of those versions or later. There is no workaround.
Patch review priority
Assess exposure and vendor guidance
- No higher-priority signal is available in the current stored evidence.
FIRST EPSS: 0.34% · percentile 27.7 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 7.5 · HIGH
- CVSS version
- 3.1
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-248, CWE-459
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:*
From (inclusive): 6.23.0
Before (exclusive): 6.29.1
cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:*
From (inclusive): 7.18.0
Before (exclusive): 7.30.1
cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:*
From (inclusive): 8.0.0
Before (exclusive): 8.12.2
These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.
Advisories and references
- https://cna.openjsf.org/security-advisories.html
Vendor Advisory
- https://github.com/nodejs/undici/security/advisories/GHSA-xjj6-f33q-929c
Vendor Advisory