AEGLIX vulnerability intelligence
CVE-2026-112900
CRITICAL · CVSS 9.2 · Analyzed
Published: 2026-10-19 · Updated: 2026-10-27 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:26:14.044316+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
Pillow is a Python imaging library. From 2.6.0 until 13.0.0, Pillow is vulnerable to argument injection when invoking Ghostscript for EPS input. EpsImagePlugin.Ghostscript passes a caller-controlled input filename after -f without converting it to a safe absolute path, so a name beginning with a hyphen can be interpreted as a Ghostscript option. An attacker who controls the filename can inject Ghostscript arguments. Arbitrary command execution specifically requires a leading @ argument-file filename and control of the referenced text file containing additional Ghostscript arguments; the reported chain reproduces with the default -dSAFER invocation. This issue is fixed in version 13.0.0.
Patch review priority
Critical technical severity
- CVSS is at least 9.0; exploitation is not established by severity alone.
FIRST EPSS: 1.06% · percentile 64.5 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 9.2 · CRITICAL
- CVSS version
- 4.0
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- Weaknesses
- CWE-78, CWE-88
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
cpe:2.3:a:python:pillow:*:*:*:*:*:*:*:*
From (inclusive): 2.6.0
Before (exclusive): 13.0.0
These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.