Skip to page content

AEGLIX MIND

Intelligence for Africa and the Gulf

AEGLIX vulnerability intelligence

CVE-2026-25199

CRITICAL · CVSS 9.1 · Modified

Published: 2026-05-08 · Updated: 2026-10-26 · Source: NVD

Stored catalog record

Source record retrieved 2026-10-28T10:20:09.828248+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.

Vulnerability overview

Instances deployed via the Proxmox extension allow unauthorized access to instances belonging to other tenants. This issue affects Apache CloudStack: from 4.21.0.0 through 4.22.0.0. The Proxmox extension for CloudStack improperly uses a user-editable instance setting, proxmox_vmid, to associate CloudStack instances with Proxmox virtual machines. Because this value is not restricted or validated against tenant ownership and Proxmox VM IDs are predictable, a non-privileged attacker can modify the setting to reference a VM belonging to another account. This allows unauthorized cross-tenant access and enables full control over the targeted VM, including starting, stopping, and destroying the virtual machine. Users are recommended to upgrade to version 4.22.0.1, which fixes this issue. As a workaround for the existing installations, editing of the proxmox_vmid instance detail by users can be prevented by adding this detail name to the global configuration parameter - user.vm.denied.details.

Patch review priority

Critical technical severity

  • CVSS is at least 9.0; exploitation is not established by severity alone.

FIRST EPSS: 0.50% · percentile 42.6 · score date 2026-10-27.

EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗

Severity and scoring

CVSS score
9.1 · CRITICAL
CVSS version
3.1
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-200

CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.

Known exploitation and remediation

Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.

Verify affected versions and patch availability in the vendor advisory before making changes.

Affected products and versions

  • cpe:2.3:a:apache:cloudstack:*:*:*:*:*:*:*:*

    From (inclusive): 4.21.0.0

    Before (exclusive): 4.22.0.1

These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.

Advisories and references

Explore official sources

Read the official NVD record ↗

Explore the CISA catalog ↗

Back to CVE intelligence