AEGLIX vulnerability intelligence
CVE-2026-27820
LOW · CVSS 1.7 · Analyzed
Published: 2026-04-16 · Updated: 2026-10-26 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:19:11.533427+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.
Patch review priority
Assess exposure and vendor guidance
- No higher-priority signal is available in the current stored evidence.
FIRST EPSS: 0.56% · percentile 46.5 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 1.7 · LOW
- CVSS version
- 4.0
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- Weaknesses
- CWE-120, CWE-131
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
cpe:2.3:a:ruby-lang:zlib:*:*:*:*:*:ruby:*:*
Before (exclusive): 3.0.1
cpe:2.3:a:ruby-lang:zlib:*:*:*:*:*:ruby:*:*
From (inclusive): 3.1.0
Before (exclusive): 3.1.2
cpe:2.3:a:ruby-lang:zlib:*:*:*:*:*:ruby:*:*
From (inclusive): 3.2.0
Before (exclusive): 3.2.3
These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.
Advisories and references
- https://github.com/ruby/zlib/security/advisories/GHSA-g857-hhfv-j68w
Vendor Advisory
- https://hackerone.com/reports/3467067
Permissions Required