AEGLIX vulnerability intelligence
CVE-2026-34380
MEDIUM · CVSS 5.9 · Analyzed
Published: 2026-04-06 · Updated: 2026-10-26 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:18:36.548452+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From 3.2.0 to before 3.2.7, 3.3.9, and 3.4.9, a signed integer overflow exists in undo_pxr24_impl() in src/lib/OpenEXRCore/internal_pxr24.c at line 377. The expression (uint64_t)(w * 3) computes w * 3 as a signed 32-bit integer before casting to uint64_t. When w is large, this multiplication constitutes undefined behavior under the C standard. On tested builds (clang/gcc without sanitizers), two's-complement wraparound commonly occurs, and for specific values of w the wrapped result is a small positive integer, which may allow the subsequent bounds check to pass incorrectly. If the check is bypassed, the decoding loop proceeds to write pixel data through dout, potentially extending far beyond the allocated output buffer. This vulnerability is fixed in 3.2.7, 3.3.9, and 3.4.9.
Patch review priority
Assess exposure and vendor guidance
- No higher-priority signal is available in the current stored evidence.
FIRST EPSS: 0.26% · percentile 17.0 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 5.9 · MEDIUM
- CVSS version
- 3.1
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:H
- Weaknesses
- CWE-190, CWE-787
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
cpe:2.3:a:openexr:openexr:*:*:*:*:*:*:*:*
From (inclusive): 3.2.0
Before (exclusive): 3.2.7
cpe:2.3:a:openexr:openexr:*:*:*:*:*:*:*:*
From (inclusive): 3.3.0
Before (exclusive): 3.3.9
cpe:2.3:a:openexr:openexr:*:*:*:*:*:*:*:*
From (inclusive): 3.4.0
Before (exclusive): 3.4.9
These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.
Advisories and references
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.2.7
Product · Release Notes
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.3.9
Product · Release Notes
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.4.9
Product · Release Notes
- https://github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-q3v8-hw4m-59w5
Exploit · Vendor Advisory