AEGLIX vulnerability intelligence
CVE-2026-40097
LOW · CVSS 3.7 · Analyzed
Published: 2026-04-10 · Updated: 2026-10-26 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:18:46.956795+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
Step CA is an online certificate authority for secure, automated certificate management for DevOps. From 0.24.0 to before 0.30.0-rc3, an attacker can trigger an index out-of-bounds panic in Step CA by sending a crafted attestation key (AK) certificate with an empty Extended Key Usage (EKU) extension during TPM device attestation. When processing a device-attest-01 ACME challenge using TPM attestation, Step CA validates that the AK certificate contains the tcg-kp-AIKCertificate Extended Key Usage OID. During this validation, the EKU extension value is decoded from its ASN.1 representation and the first element is checked. A crafted certificate could include an EKU extension that decodes to an empty sequence, causing the code to panic when accessing the first element of the empty slice. This vulnerability is only reachable when a device-attest-01 ACME challenge with TPM attestation is configured. Deployments not using TPM device attestation are not affected. This vulnerability is fixed in 0.30.0-rc3.
Patch review priority
Assess exposure and vendor guidance
- No higher-priority signal is available in the current stored evidence.
FIRST EPSS: 0.18% · percentile 7.6 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 3.7 · LOW
- CVSS version
- 3.1
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-129
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
cpe:2.3:a:smallstep:step-ca:*:*:*:*:*:go:*:*
From (inclusive): 0.24.0
Before (exclusive): 0.30.0
cpe:2.3:a:smallstep:step-ca:0.30.0:rc1:*:*:*:go:*:*
cpe:2.3:a:smallstep:step-ca:0.30.0:rc2:*:*:*:go:*:*
These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.
Advisories and references
- https://github.com/smallstep/certificates/commit/ffd31ac0a87e03b0224cb8363094bfe602242888
Patch
- https://github.com/smallstep/certificates/pull/2569
Issue Tracking · Patch
- https://github.com/smallstep/certificates/releases/tag/v0.30.0
Product · Release Notes
- https://github.com/smallstep/certificates/security/advisories/GHSA-9qq8-cgcv-qmc9
Mitigation · Vendor Advisory