Skip to page content

AEGLIX MIND

Intelligence for Africa and the Gulf

AEGLIX vulnerability intelligence

CVE-2026-40296

MEDIUM · CVSS 5.4 · Analyzed

Published: 2026-05-06 · Updated: 2026-10-26 · Source: NVD

Stored catalog record

Source record retrieved 2026-10-28T10:20:04.654018+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.

Vulnerability overview

PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. The HTML writer skips htmlspecialchars escaping when a cell's formatted value differs from the original value. When a cell has a custom number format containing the text placeholder @ along with any additional literal characters (for example ". @", "@ ", or "x@"), the formatter replaces @ with the cell value and adds the extra characters, causing the formatted value to differ from the original and bypassing HTML escaping entirely. An attacker who can control the cell value and number format of an uploaded spreadsheet that is later converted to HTML and displayed to other users can achieve stored cross-site scripting. This issue is fixed in versions 5.7.0, 3.10.5, 2.4.5, 2.1.16, and 1.30.4.

Patch review priority

Assess exposure and vendor guidance

  • No higher-priority signal is available in the current stored evidence.

FIRST EPSS: 0.22% · percentile 13.1 · score date 2026-10-27.

EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗

Severity and scoring

CVSS score
5.4 · MEDIUM
CVSS version
3.1
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79

CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.

Known exploitation and remediation

Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.

Verify affected versions and patch availability in the vendor advisory before making changes.

Affected products and versions

  • cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*

    Before (exclusive): 1.30.4

  • cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*

    From (inclusive): 2.0.0

    Before (exclusive): 2.1.16

  • cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*

    From (inclusive): 2.2.0

    Before (exclusive): 2.4.5

  • cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*

    From (inclusive): 3.3.0

    Before (exclusive): 3.10.5

  • cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*

    From (inclusive): 4.0.0

    Before (exclusive): 5.7.0

These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.

Advisories and references

Explore official sources

Read the official NVD record ↗

Explore the CISA catalog ↗

Back to CVE intelligence