AEGLIX vulnerability intelligence
CVE-2026-40902
HIGH · CVSS 7.5 · Analyzed
Published: 2026-05-12 · Updated: 2026-10-26 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:24:49.661752+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0, the XLSX reader's ColumnAndRowAttributes::readRowAttributes() method reads row numbers from XML attributes without validating them against the spreadsheet maximum row limit (AddressRange::MAX_ROW = 1,048,576). An attacker can craft a minimal XLSX file (~1.6KB) containing a <row r="999999999"/> element that inflates cachedHighestRow to 999,999,999, causing any subsequent row iteration to attempt ~1 billion loop cycles and exhaust CPU resources. This vulnerability is fixed in 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0.
Patch review priority
Assess exposure and vendor guidance
- No higher-priority signal is available in the current stored evidence.
FIRST EPSS: 0.40% · percentile 33.5 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 7.5 · HIGH
- CVSS version
- 3.1
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-770
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*
Before (exclusive): 1.30.4
cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*
From (inclusive): 2.0.0
Before (exclusive): 2.1.16
cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*
From (inclusive): 2.2.0
Before (exclusive): 2.4.5
cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*
From (inclusive): 3.3.0
Before (exclusive): 3.10.5
cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*
From (inclusive): 4.0.0
Before (exclusive): 5.7.0
These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.
Advisories and references
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-7c6m-4442-2x6m
Exploit · Mitigation · Vendor Advisory
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-7c6m-4442-2x6m
Exploit · Mitigation · Vendor Advisory