Skip to page content

AEGLIX MIND

Intelligence for Africa and the Gulf

AEGLIX vulnerability intelligence

CVE-2026-40982

CRITICAL · CVSS 9.1 · Modified

Published: 2026-05-07 · Updated: 2026-10-26 · Source: NVD

Stored catalog record

Source record retrieved 2026-10-28T10:20:04.872275+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.

Vulnerability overview

Spring Cloud Config allows applications to serve arbitrary text and binary files through the spring-cloud-config-server module. A malicious user, or attacker, can send a request using a specially crafted URL that can lead to a directory traversal attack. Spring Cloud Config 3.1.x: affected from 3.1.0 through 3.1.13 (inclusive); upgrade to 3.1.14 or greater (Enterprise Support Only). Spring Cloud Config 4.1.x: affected from 4.1.0 through 4.1.9 (inclusive); upgrade to 4.1.10 or greater (Enterprise Support Only). Spring Cloud Config 4.2.x: affected from 4.2.0 through 4.2.6 (inclusive); upgrade to 4.2.7 or greater (Enterprise Support Only). Spring Cloud Config 4.3.x: affected from 4.3.0 through 4.3.2 (inclusive); upgrade to 4.3.3 or greater. Spring Cloud Config 5.0.x: affected from 5.0.0 through 5.0.2 (inclusive); upgrade to 5.0.3 or greater.

Patch review priority

Critical technical severity

  • CVSS is at least 9.0; exploitation is not established by severity alone.

FIRST EPSS: 0.73% · percentile 53.9 · score date 2026-10-27.

EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗

Severity and scoring

CVSS score
9.1 · CRITICAL
CVSS version
3.1
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-22

CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.

Known exploitation and remediation

Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.

Verify affected versions and patch availability in the vendor advisory before making changes.

Affected products and versions

  • cpe:2.3:a:vmware:spring_cloud_config:*:*:*:*:*:*:*:*

    From (inclusive): 3.1.0

    Before (exclusive): 3.1.14

  • cpe:2.3:a:vmware:spring_cloud_config:*:*:*:*:*:*:*:*

    From (inclusive): 4.1.0

    Before (exclusive): 4.1.10

  • cpe:2.3:a:vmware:spring_cloud_config:*:*:*:*:*:*:*:*

    From (inclusive): 4.2.0

    Before (exclusive): 4.2.7

  • cpe:2.3:a:vmware:spring_cloud_config:*:*:*:*:*:*:*:*

    From (inclusive): 4.3.0

    Before (exclusive): 4.3.3

  • cpe:2.3:a:vmware:spring_cloud_config:*:*:*:*:*:*:*:*

    From (inclusive): 5.0.0

    Before (exclusive): 5.0.3

These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.

Advisories and references

Explore official sources

Read the official NVD record ↗

Explore the CISA catalog ↗

Back to CVE intelligence