AEGLIX vulnerability intelligence
CVE-2026-41044
HIGH · CVSS 8.8 · Modified
Published: 2026-04-24 · Updated: 2026-10-26 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:19:37.706744+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ, Apache ActiveMQ Broker, Apache ActiveMQ All. An authenticated attacker can use the admin web console page to construct a malicious broker name that bypasses name validation to include an xbean binding that can be later used by a VM transport to load a remote Spring XML application. The attacker can then use the DestinationView mbean to send a message to trigger a VM transport creation that will reference this malicious broker name which can lead to loading the malicious Spring XML context file. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Broker: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ All: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.
Patch review priority
Assess exposure and vendor guidance
- No higher-priority signal is available in the current stored evidence.
FIRST EPSS: 0.98% · percentile 62.0 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 8.8 · HIGH
- CVSS version
- 3.1
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20, CWE-94
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*
Before (exclusive): 5.19.6
cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*
From (inclusive): 6.0.0
Before (exclusive): 6.2.5
cpe:2.3:a:apache:activemq_broker:*:*:*:*:*:*:*:*
Before (exclusive): 5.19.6
cpe:2.3:a:apache:activemq_broker:*:*:*:*:*:*:*:*
From (inclusive): 6.0.0
Before (exclusive): 6.2.5
These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.
Advisories and references
- https://activemq.apache.org/security-advisories.data/CVE-2026-41044-announcement.txt
Mailing List · Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/04/23/6
Mailing List · Third Party Advisory
- https://access.redhat.com/security/cve/CVE-2026-41044
- https://bugzilla.redhat.com/show_bug.cgi?id=2461409
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-41044.json