AEGLIX vulnerability intelligence
CVE-2026-41264
CRITICAL · CVSS 9.2 · Analyzed
Published: 2026-04-23 · Updated: 2026-10-26 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:19:35.400887+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, the specific flaw exists within the run method of the CSV_Agents class. The issue results from the lack of proper sandboxing when evaluating an LLM generated python script. An attacker can leverage this vulnerability to execute code in the context of the user running the server. Using prompt injection techniques, an unauthenticated attacker with the ability to send prompts to a chatflow using the CSV Agent node may convince an LLM to respond with a malicious python script that executes attacker controlled commands on the Flowise server. This vulnerability is fixed in 3.1.0.
Patch review priority
Critical technical severity
- CVSS is at least 9.0; exploitation is not established by severity alone.
FIRST EPSS: 1.79% · percentile 78.2 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 9.2 · CRITICAL
- CVSS version
- 4.0
- CVSS vector
- CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- Weaknesses
- CWE-184
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
cpe:2.3:a:flowiseai:flowise:*:*:*:*:*:*:*:*
Before (exclusive): 3.1.0
These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.
Advisories and references
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-3hjv-c53m-58jj
Exploit · Vendor Advisory
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-3hjv-c53m-58jj
Exploit · Vendor Advisory