AEGLIX vulnerability intelligence
CVE-2026-42088
CRITICAL · CVSS 9.6 · Analyzed
Published: 2026-05-04 · Updated: 2026-10-26 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:19:58.228614+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
OpenC3 COSMOS provides the functionality needed to send commands to and receive data from one or more embedded systems. Prior to version 7.0.0-rc3, the Script Runner widget allows users to execute Python and Ruby scripts directly from the openc3-COSMOS-script-runner-api container. Because all the docker containers share a network, users can execute specially crafted scripts to bypass the API permissions check and perform administrative actions, including reading and modifying data inside the Redis database, which can be used to read secrets and change COSMOS settings, as well as read and write to the buckets service, which holds configuration, log, and plugin files. These actions are normally only available from the Admin Console or with administrative privileges. Any user with permission to create and run scripts can connect to any service in the docker network. This issue has been patched in version 7.0.0-rc3.
Patch review priority
Critical technical severity
- CVSS is at least 9.0; exploitation is not established by severity alone.
FIRST EPSS: 0.34% · percentile 27.5 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 9.6 · CRITICAL
- CVSS version
- 3.1
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
- Weaknesses
- CWE-250
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
cpe:2.3:a:openc3:cosmos:*:*:*:*:open_source:*:*:*
Before (exclusive): 7.0.0
cpe:2.3:a:openc3:cosmos:7.0.0:rc1:*:*:open_source:*:*:*
cpe:2.3:a:openc3:cosmos:7.0.0:rc2:*:*:open_source:*:*:*
These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.
Advisories and references
- https://github.com/OpenC3/cosmos/releases/tag/v7.0.0
Release Notes
- https://github.com/OpenC3/cosmos/releases/tag/v7.0.0-rc3
Release Notes
- https://github.com/OpenC3/cosmos/security/advisories/GHSA-2wvh-87g2-89hr
Exploit · Vendor Advisory
- https://github.com/OpenC3/cosmos/security/advisories/GHSA-2wvh-87g2-89hr
Exploit · Vendor Advisory