Skip to page content

AEGLIX MIND

Intelligence for Africa and the Gulf

AEGLIX vulnerability intelligence

CVE-2026-42271

HIGH · CVSS 8.7 · Analyzed

Published: 2026-05-08 · Updated: 2026-10-26 · Source: NVD

Stored catalog record

Source record retrieved 2026-10-28T10:20:09.043868+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.

Vulnerability overview

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.

Patch review priority

Known exploitation: prioritize review

  • CISA KEV lists real-world exploitation.

FIRST EPSS: 91.44% · percentile 99.8 · score date 2026-10-27.

EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗

Severity and scoring

CVSS score
8.7 · HIGH
CVSS version
4.0
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weaknesses
CWE-77, CWE-78

CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.

Known exploitation and remediation

Listed in CISA’s Known Exploited Vulnerabilities catalog.

Affected product
BerriAI · LiteLLM
Added to catalog
2026-06-08
Required action
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
CISA remediation due date
2026-06-22

CISA deadlines apply to the organizations covered by its directives. Confirm your own remediation requirements.

Verify affected versions and patch availability in the vendor advisory before making changes.

Affected products and versions

  • cpe:2.3:a:litellm:litellm:*:*:*:*:*:*:*:*

    From (inclusive): 1.74.2

    Before (exclusive): 1.83.7

  • cpe:2.3:a:redhat:openshift_ai:*:*:*:*:*:*:*:*

    From (inclusive): 2.25

    Before (exclusive): 2.25.8

  • cpe:2.3:a:redhat:openshift_ai:*:*:*:*:*:*:*:*

    From (inclusive): 3.3

    Before (exclusive): 3.3.4

  • cpe:2.3:a:redhat:openshift_ai:3.4:*:*:*:*:*:*:*

These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.

Advisories and references

Explore official sources

Read the official NVD record ↗

Explore the CISA catalog ↗

Back to CVE intelligence