AEGLIX vulnerability intelligence
CVE-2026-42334
HIGH · CVSS 7.5 · Analyzed
Published: 2026-05-14 · Updated: 2026-10-26 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:25:02.444489+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Prior to 6.13.9, 7.8.9, 8.22.1, and 9.1.6, a vulnerability allows bypassing Mongoose’s sanitizeFilter query sanitization mechanism via the $nor operator. When sanitizeFilter is enabled, Mongoose wraps query operators in $eq to neutralize them. However, prior to the fix, $nor was not included in the set of logical operators that are recursively sanitized. Because $nor accepts an array (like $and and $or), and arrays do not trigger hasDollarKeys(), malicious operators such as $ne, $gt, or $regex could be injected inside a $nor clause without being sanitized. This vulnerability is fixed in 6.13.9, 7.8.9, 8.22.1, and 9.1.6.
Patch review priority
Assess exposure and vendor guidance
- No higher-priority signal is available in the current stored evidence.
FIRST EPSS: 0.27% · percentile 19.7 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 7.5 · HIGH
- CVSS version
- 3.1
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-74
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
cpe:2.3:a:mongoosejs:mongoose:*:*:*:*:*:node.js:*:*
Before (exclusive): 6.13.9
cpe:2.3:a:mongoosejs:mongoose:*:*:*:*:*:node.js:*:*
From (inclusive): 7.0.0
Before (exclusive): 7.8.9
cpe:2.3:a:mongoosejs:mongoose:*:*:*:*:*:node.js:*:*
From (inclusive): 8.0.0
Before (exclusive): 8.22.1
cpe:2.3:a:mongoosejs:mongoose:*:*:*:*:*:node.js:*:*
From (inclusive): 9.0.0
Before (exclusive): 9.1.6
These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.
Advisories and references
- https://github.com/Automattic/mongoose/security/advisories/GHSA-wpg9-53fq-2r8h
Mitigation · Vendor Advisory