Skip to page content

AEGLIX MIND

Intelligence for Africa and the Gulf

AEGLIX vulnerability intelligence

CVE-2026-4296

HIGH · CVSS 7.5 · Analyzed

Published: 2026-04-21 · Updated: 2026-10-26 · Source: NVD

Stored catalog record

Source record retrieved 2026-10-28T10:19:30.310285+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.

Vulnerability overview

An incorrect regular expression vulnerability was identified in GitHub Enterprise Server that allowed an attacker to bypass OAuth redirect URI validation. An attacker with knowledge of a first-party OAuth application's registered callback URL could craft a malicious authorization link that, when clicked by a victim, would redirect the OAuth authorization code to an attacker-controlled domain. This could allow the attacker to gain unauthorized access to the victim's account with the scopes granted to the OAuth application. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.20.1, 3.19.5, 3.18.8, 3.17.14, 3.16.17, 3.15.21, 3.14.26. This vulnerability was reported via the GitHub Bug Bounty program.

Patch review priority

Assess exposure and vendor guidance

  • No higher-priority signal is available in the current stored evidence.

FIRST EPSS: 0.43% · percentile 36.6 · score date 2026-10-27.

EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗

Severity and scoring

CVSS score
7.5 · HIGH
CVSS version
4.0
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weaknesses
CWE-185

CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.

Known exploitation and remediation

Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.

Verify affected versions and patch availability in the vendor advisory before making changes.

Affected products and versions

  • cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:*

    Before (exclusive): 3.14.26

  • cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:*

    From (inclusive): 3.15.0

    Before (exclusive): 3.15.21

  • cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:*

    From (inclusive): 3.16.0

    Before (exclusive): 3.16.17

  • cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:*

    From (inclusive): 3.17.0

    Before (exclusive): 3.17.14

  • cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:*

    From (inclusive): 3.18.0

    Before (exclusive): 3.18.8

  • cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:*

    From (inclusive): 3.19.0

    Before (exclusive): 3.19.5

  • cpe:2.3:a:github:enterprise_server:3.20.0:*:*:*:*:*:*:*

These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.

Advisories and references

Explore official sources

Read the official NVD record ↗

Explore the CISA catalog ↗

Back to CVE intelligence