AEGLIX vulnerability intelligence
CVE-2026-43930
LOW · CVSS 2.1 · Analyzed
Published: 2026-05-12 · Updated: 2026-10-26 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:24:41.890504+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 8.6.76 and 9.9.0-alpha.2, a race condition in the MFA SMS one-time password (OTP) login path allows two concurrent /login requests carrying the same OTP to both succeed and both receive valid session tokens, breaking the single-use property of the OTP. The vulnerability requires the attacker to already possess the victim's password and intercept the active SMS OTP (e.g. via SIM swap, network mirror, or phishing relay) and to race the legitimate login request, so the practical attack surface is narrow. This vulnerability is fixed in 8.6.76 and 9.9.0-alpha.2.
Patch review priority
Assess exposure and vendor guidance
- No higher-priority signal is available in the current stored evidence.
FIRST EPSS: 0.24% · percentile 14.5 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 2.1 · LOW
- CVSS version
- 4.0
- CVSS vector
- CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- Weaknesses
- CWE-362
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:*
Before (exclusive): 8.6.76
cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:*
From (inclusive): 9.0.0
Before (exclusive): 9.9.0
cpe:2.3:a:parseplatform:parse-server:9.9.0:alpha1:*:*:*:node.js:*:*
These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.
Advisories and references
- https://github.com/parse-community/parse-server/pull/10448
Issue Tracking · Patch
- https://github.com/parse-community/parse-server/pull/10449
Issue Tracking · Patch
- https://github.com/parse-community/parse-server/security/advisories/GHSA-jpq4-7fmq-q5fj
Mitigation · Vendor Advisory