Skip to page content

AEGLIX MIND

Intelligence for Africa and the Gulf

AEGLIX vulnerability intelligence

CVE-2026-44437

MEDIUM · CVSS 6.9 · Analyzed

Published: 2026-05-13 · Updated: 2026-10-26 · Source: NVD

Stored catalog record

Source record retrieved 2026-10-28T10:25:01.057984+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.

Continue your research

Connect this record to stored reporting, reviewed campaign mentions and source-domain investigation. These are research leads, not inferred attack relationships.

Open CVE research in Investigate · Find Arsenal listings referencing this CVE

Vulnerability overview

The Angular SSR is a server-rise rendering tool for Angular applications. From 19.0.0-next.0 to before 19.2.25, 20.3.25, 21.2.9, and 22.0.0-next.7, a vulnerability exists in the X-Forwarded-Prefix header processing logic within Angular SSR. The internal validation mechanism fails to properly account for URL-encoded characters, specifically dots (%2e%2e). This allows an attacker to bypass security filters by injecting encoded path traversal sequences that are later decoded and utilized by the application logic. When an Angular SSR application is configured to trust proxy headers and is deployed behind a proxy that forwards the X-Forwarded-Prefix header without prior sanitization, an attacker can provide a payload such as /%2e%2e/evil. This vulnerability is fixed in19.2.25, 20.3.25, 21.2.9, and 22.0.0-next.7.

Patch review priority

Assess exposure and vendor guidance

  • No higher-priority signal is available in the current stored evidence.

FIRST EPSS: 0.20% · percentile 10.2 · score date 2026-10-28.

EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗

Severity and scoring

CVSS score
6.9 · MEDIUM
CVSS version
4.0
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weaknesses
CWE-22, CWE-601

CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.

Known exploitation and remediation

Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.

Verify affected versions and patch availability in the vendor advisory before making changes.

Affected products and versions

  • cpe:2.3:a:angular:angular_cli:*:*:*:*:*:node.js:*:*

    From (inclusive): 19.0.0

    Before (exclusive): 19.2.25

  • cpe:2.3:a:angular:angular_cli:*:*:*:*:*:node.js:*:*

    From (inclusive): 20.0.0

    Before (exclusive): 20.3.25

  • cpe:2.3:a:angular:angular_cli:*:*:*:*:*:node.js:*:*

    From (inclusive): 21.0.0

    Before (exclusive): 21.2.9

  • cpe:2.3:a:angular:angular_cli:22.0.0:next0:*:*:*:node.js:*:*

  • cpe:2.3:a:angular:angular_cli:22.0.0:next1:*:*:*:node.js:*:*

  • cpe:2.3:a:angular:angular_cli:22.0.0:next2:*:*:*:node.js:*:*

  • cpe:2.3:a:angular:angular_cli:22.0.0:next3:*:*:*:node.js:*:*

  • cpe:2.3:a:angular:angular_cli:22.0.0:next4:*:*:*:node.js:*:*

  • cpe:2.3:a:angular:angular_cli:22.0.0:next5:*:*:*:node.js:*:*

  • cpe:2.3:a:angular:angular_cli:22.0.0:next6:*:*:*:node.js:*:*

These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.

Advisories and references

Explore official sources

Read the official NVD record ↗

Explore the CISA catalog ↗

Back to CVE intelligence