AEGLIX vulnerability intelligence
CVE-2026-44577
MEDIUM · CVSS 5.9 · Modified
Published: 2026-05-13 · Updated: 2026-10-26 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:24:57.169277+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
Next.js is a React framework for building full-stack web applications. From 10.0.0 to before 15.5.16 and 16.2.5, when self-hosting Next.js with the default image loader, the Image Optimization API fetches local images entirely into memory without enforcing a maximum size limit. An attacker could cause out-of-memory conditions by requesting large local assets from the /_next/image endpoint that match the images.localPatterns configuration (by default, all patterns are allowed). This vulnerability is fixed in 15.5.16 and 16.2.5.
Patch review priority
Assess exposure and vendor guidance
- No higher-priority signal is available in the current stored evidence.
FIRST EPSS: 0.74% · percentile 54.3 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 5.9 · MEDIUM
- CVSS version
- 3.1
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-770
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*
From (inclusive): 10.0.0
Before (exclusive): 15.5.16
cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*
From (inclusive): 16.0.0
Before (exclusive): 16.2.5
These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.
Advisories and references
- https://github.com/vercel/next.js/security/advisories/GHSA-h64f-5h5j-jqjh
Mitigation · Vendor Advisory
- https://access.redhat.com/errata/RHSA-2026:34608
- https://access.redhat.com/errata/RHSA-2026:37272
- https://access.redhat.com/errata/RHSA-2026:40974
- https://access.redhat.com/errata/RHSA-2026:54435
- https://access.redhat.com/security/cve/CVE-2026-44577
- https://bugzilla.redhat.com/show_bug.cgi?id=2477194
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44577.json