AEGLIX vulnerability intelligence
CVE-2026-44578
HIGH · CVSS 8.6 · Modified
Published: 2026-05-13 · Updated: 2026-10-26 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:24:57.606300+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-hosted applications using the built-in Node.js server can be vulnerable to server-side request forgery through crafted WebSocket upgrade requests. An attacker can cause the server to proxy requests to arbitrary internal or external destinations, which may expose internal services or cloud metadata endpoints. Vercel-hosted deployments are not affected. This vulnerability is fixed in 15.5.16 and 16.2.5.
Patch review priority
Elevated predicted exploitation
- EPSS probability is at least 10%; this is a published triage threshold, not a combined risk score.
FIRST EPSS: 35.54% · percentile 98.4 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 8.6 · HIGH
- CVSS version
- 3.1
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
- Weaknesses
- CWE-918
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*
From (inclusive): 13.4.13
Before (exclusive): 15.5.16
cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*
From (inclusive): 16.0.0
Before (exclusive): 16.2.5
These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.
Advisories and references
- https://github.com/vercel/next.js/security/advisories/GHSA-c4j6-fc7j-m34r
Mitigation · Vendor Advisory
- https://access.redhat.com/errata/RHSA-2026:34608
- https://access.redhat.com/errata/RHSA-2026:37272
- https://access.redhat.com/errata/RHSA-2026:40974
- https://access.redhat.com/errata/RHSA-2026:54435
- https://access.redhat.com/security/cve/CVE-2026-44578
- https://bugzilla.redhat.com/show_bug.cgi?id=2477187
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44578.json