Skip to page content

AEGLIX MIND

Intelligence for Africa and the Gulf

AEGLIX vulnerability intelligence

CVE-2026-48779

HIGH · CVSS 7.5 · Modified

Published: 2026-06-17 · Updated: 2026-10-26 · Source: NVD

Stored catalog record

Source record retrieved 2026-10-28T10:25:41.193226+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.

Vulnerability overview

ws is an open source WebSocket client and server for Node.js. All versions from 1.1.0 up to (but not including) 5.2.5, from 6.0.0 up to 6.2.4, from 7.0.0 up to 7.5.11, and from 8.0.0 up to 8.21.0 are affected by a memory exhaustion DoS vulnerability. A peer can send a high volume of exceptionally small fragments and data chunks, with modest network traffic, to force the remote peer into allocating and holding structural wrappers that consume far more memory than the default documented message-size limit, leading to process termination due to OOM. This issue has been fixed in versions 5.2.5, 6.2.4, 7.5.11, and 8.21.0.

Patch review priority

Assess exposure and vendor guidance

  • No higher-priority signal is available in the current stored evidence.

FIRST EPSS: 1.43% · percentile 72.8 · score date 2026-10-27.

EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗

Severity and scoring

CVSS score
7.5 · HIGH
CVSS version
3.1
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-1050, CWE-400, CWE-770

CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.

Known exploitation and remediation

Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.

Verify affected versions and patch availability in the vendor advisory before making changes.

Affected products and versions

  • cpe:2.3:a:ws_project:ws:*:*:*:*:*:node.js:*:*

    From (inclusive): 1.1.0

    Before (exclusive): 5.2.5

  • cpe:2.3:a:ws_project:ws:*:*:*:*:*:node.js:*:*

    From (inclusive): 6.0.0

    Before (exclusive): 6.2.4

  • cpe:2.3:a:ws_project:ws:*:*:*:*:*:node.js:*:*

    From (inclusive): 7.0.0

    Before (exclusive): 7.5.11

  • cpe:2.3:a:ws_project:ws:*:*:*:*:*:node.js:*:*

    From (inclusive): 8.0.0

    Before (exclusive): 8.21.0

These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.

Advisories and references

Explore official sources

Read the official NVD record ↗

Explore the CISA catalog ↗

Back to CVE intelligence