AEGLIX vulnerability intelligence
CVE-2026-49869
CRITICAL · CVSS 10.0 · Analyzed
Published: 2026-06-26 · Updated: 2026-10-25 · Source: NVD
Vulnerability overview
Kestra is an open-source, event-driven orchestration platform. Prior to 1.0.45 and 1.3.21, AuthenticationFilter in Kestra OSS uses request.getPath().endsWith("/configs") to whitelist the public configuration endpoint from Basic Auth. Because the check is a suffix match rather than an exact path match, any API path whose last segment is configs bypasses authentication entirely. An unauthenticated remote attacker can exploit this to create and execute arbitrary workflows without credentials. Because Kestra ships with script execution plugins (plugin-script-shell, plugin-script-python, etc.) enabled by default, this directly results in unauthenticated Remote Code Execution as root inside the Kestra worker container. This vulnerability is fixed in 1.0.45 and 1.3.21.
Severity and scoring
- CVSS score
- 10.0 · CRITICAL
- CVSS version
- 3.1
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-184, CWE-287, CWE-78, CWE-918
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Listed in CISA’s Known Exploited Vulnerabilities catalog.
- Affected product
- Kestra · Kestra OSS
- Added to catalog
- 2026-09-02
- Required action
- Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
- CISA remediation due date
- 2026-09-05
CISA deadlines apply to the organizations covered by its directives. Confirm your own remediation requirements.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
cpe:2.3:a:kestra:kestra:*:*:*:*:*:*:*:*
Before (exclusive): 1.0.45
cpe:2.3:a:kestra:kestra:*:*:*:*:*:*:*:*
From (inclusive): 1.1.0
Before (exclusive): 1.3.21
These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.
Advisories and references
- https://github.com/kestra-io/kestra/security/advisories/GHSA-5vc5-wxxq-3fjx
Exploit · Vendor Advisory
- https://github.com/kestra-io/kestra/security/advisories/GHSA-5vc5-wxxq-3fjx
Exploit · Vendor Advisory
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-49869
US Government Resource