AEGLIX vulnerability intelligence
CVE-2026-57199
LOW · CVSS 2.3 · Received
Published: 2026-10-27 · Updated: 2026-10-27 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:28:00.937210+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, `app_sms.c` copies externally controlled `SMS` lengths into `fixed in-struct buffers` without sufficient bounds checks, allowing an attacker to corrupt memory or crash Asterisk. The administrator must explicitly use the `SMS` dialplan application, which is useful when routing calls to or from `analog devices`, and must not have ensured that data passed to the application is valid. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.
Patch review priority
Assess exposure and vendor guidance
- No higher-priority signal is available in the current stored evidence.
- Fresh EPSS data is unavailable; missing values are not zero.
EPSS unavailable; no zero score is assumed.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 2.3 · LOW
- CVSS version
- 4.0
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- Weaknesses
- CWE-787
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
NVD has not supplied affected-version configurations for this record. Check the vendor references below.
Advisories and references
- https://github.com/asterisk/asterisk/commit/15c66022dc441ec63d7bd5f53cf7f35db72964be
- https://github.com/asterisk/asterisk/commit/38a2059eb77a91a6b6e76eeba5875c2b96027368
- https://github.com/asterisk/asterisk/commit/59b74276f24ba104d859f3f05897c9b8d835a28a
- https://github.com/asterisk/asterisk/commit/60f4ef3deac6b9af30519b46c13f103264038b82
- https://github.com/asterisk/asterisk/commit/661d6a2fc5cc7744ab9d849ed3c73ae5066386df
- https://github.com/asterisk/asterisk/commit/7048a3841df99e090b9d87246600373581629c98
- https://github.com/asterisk/asterisk/commit/f46f63bd4d33665d336cf8b5998650b915222549
- https://github.com/asterisk/asterisk/releases/tag/20.20.1
- https://github.com/asterisk/asterisk/releases/tag/21.12.3
- https://github.com/asterisk/asterisk/releases/tag/22.10.1
- https://github.com/asterisk/asterisk/releases/tag/23.4.1
- https://github.com/asterisk/asterisk/releases/tag/certified-20.7-cert11
- https://github.com/asterisk/asterisk/releases/tag/certified-22.8-cert3
- https://github.com/asterisk/asterisk/security/advisories/GHSA-q9fr-m7g8-6ph5
- https://github.com/asterisk/asterisk/tree/24.0.0-pre1