AEGLIX vulnerability intelligence
CVE-2026-58392
MEDIUM · CVSS 5.4 · Deferred
Published: 2026-10-15 · Updated: 2026-10-15 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:22:43.275193+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
OPNsense is a FreeBSD based firewall and routing platform. Prior to version 26.1.11, the NTP GPS page stores the operator-supplied initcmd value in base64 form, applies legacy_html_escape_form_data() to the encoded string, and then uses base64_decode() to decode the value directly into the GPS initialization-command textarea in src/www/services_ntpd_gps.php. Because decoding occurs after escaping, stored HTML remains unescaped at the output sink. A user with page-services-ntp-gps privilege can store a value that closes the textarea, and script executes in the session of any user who later opens the GPS page. The script can read CSRF material and perform authenticated actions, including actions available to an administrator. This issue is fixed in version 26.1.11.
Patch review priority
Assess exposure and vendor guidance
- No higher-priority signal is available in the current stored evidence.
FIRST EPSS: 0.27% · percentile 19.6 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 5.4 · MEDIUM
- CVSS version
- 3.1
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
NVD has not supplied affected-version configurations for this record. Check the vendor references below.
Advisories and references
- https://github.com/opnsense/core/commit/a92d9514b5436c868f8f97138ebed507f6de423c
- https://github.com/opnsense/core/commit/ed04a154dc40967541be1388e9134e451be4199e
- https://github.com/opnsense/core/security/advisories/GHSA-h793-67jm-j4m5
- https://hackerask.com/posts/opnsense
- https://github.com/opnsense/core/security/advisories/GHSA-h793-67jm-j4m5