AEGLIX vulnerability intelligence
CVE-2026-58393
MEDIUM · CVSS 5.9 · Deferred
Published: 2026-10-15 · Updated: 2026-10-15 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:22:43.299418+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
OPNsense is a FreeBSD based firewall and routing platform. Prior to version 26.1.11, the OpenVPN Client Specific Override common_name field accepts path traversal sequences and openvpn_csc_conf_write() concatenates the value into /var/etc/openvpn-csc/<vpnid>/<common_name> without normalization or a basename check. The affected event handlers are client_connect.php and user_pass_verify.php. An authenticated user with Client Specific Override privileges can store the traversal value, and a matching OpenVPN client-connect or authentication event causes a generated CSO file to be written outside the intended directory. The file content is generated OpenVPN configuration rather than arbitrary bytes, and practical exploitation requires the attacker to cause a matching common name or username to be processed. This issue is fixed in version 26.1.11.
Patch review priority
Assess exposure and vendor guidance
- No higher-priority signal is available in the current stored evidence.
FIRST EPSS: 0.43% · percentile 37.4 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 5.9 · MEDIUM
- CVSS version
- 3.1
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:L
- Weaknesses
- CWE-22
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
NVD has not supplied affected-version configurations for this record. Check the vendor references below.
Advisories and references
- https://github.com/opnsense/core/commit/3af496143a19153c18b2f9458b2510d58aff2b98
- https://github.com/opnsense/core/commit/6101b3e2c90482111f420a47775c14a447441a72
- https://github.com/opnsense/core/security/advisories/GHSA-2m9v-p7r9-gfcw
- https://github.com/opnsense/core/security/advisories/GHSA-2m9v-p7r9-gfcw