AEGLIX vulnerability intelligence
CVE-2026-58395
MEDIUM · CVSS 4.3 · Deferred
Published: 2026-10-15 · Updated: 2026-10-15 · Source: NVD
Stored catalog record
Source record retrieved 2026-10-28T10:22:43.347958+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.
Vulnerability overview
OPNsense is a FreeBSD based firewall and routing platform. Prior to version 26.1.11, the safe-delete path reached through ApiMutableModelControllerBase::delBase() interpolates an unvalidated safe-delete token from the request URL into an XPath expression over config.xml before confirming that the token is a valid identifier. A user holding any one affected module privilege can send a crafted token to one of 21 affected delete endpoints covering Traffic Shaper, DHCP relay, Dnsmasq, Firewall Category, or Kea DHCP, causing the XPath to match configuration data across modules. The resulting error response exposes configuration item names, descriptions, reference paths, and UUIDs and provides an XPath substring-presence oracle, including for modules the user cannot otherwise access. The request does not modify configuration or perform a deletion. This issue is fixed in version 26.1.11.
Patch review priority
Assess exposure and vendor guidance
- No higher-priority signal is available in the current stored evidence.
FIRST EPSS: 0.36% · percentile 29.2 · score date 2026-10-27.
EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗
Severity and scoring
- CVSS score
- 4.3 · MEDIUM
- CVSS version
- 3.1
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-643
CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.
Known exploitation and remediation
Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.
Verify affected versions and patch availability in the vendor advisory before making changes.
Affected products and versions
NVD has not supplied affected-version configurations for this record. Check the vendor references below.
Advisories and references
- https://github.com/opnsense/core/commit/631e14721b311badc1d3c0d29321e4d42585156b
- https://github.com/opnsense/core/commit/d7054cef69f72588feac1091254960835be19dfe
- https://github.com/opnsense/core/security/advisories/GHSA-98h6-479q-9q3w
- https://hackerask.com/posts/opnsense
- https://github.com/opnsense/core/security/advisories/GHSA-98h6-479q-9q3w