Skip to page content

AEGLIX MIND

Intelligence for Africa and the Gulf

AEGLIX vulnerability intelligence

CVE-2026-5845

HIGH · CVSS 7.2 · Analyzed

Published: 2026-04-21 · Updated: 2026-10-26 · Source: NVD

Stored catalog record

Source record retrieved 2026-10-28T10:19:30.360798+00:00. Scheduled imports handle updates; this page does not assert that the provider was queried just now.

Vulnerability overview

An improper authorization vulnerability in scoped user-to-server (ghu_) token authorization in GitHub Enterprise Server allows an authenticated attacker to access private repositories outside the intended installation scope, which can include write operations, via an authorization fallback that treated a revoked/deleted installation as a global installation context, which could be chained with token revocation timing and SSH push attribution to obtain and reuse a victim-scoped token. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.20.1, 3.19.5, 3.18.8, 3.17.14, 3.16.17, 3.15.21, and 3.14.26. This vulnerability was reported via the GitHub Bug Bounty program.

Patch review priority

Assess exposure and vendor guidance

  • No higher-priority signal is available in the current stored evidence.

FIRST EPSS: 0.29% · percentile 21.5 · score date 2026-10-27.

EPSS estimates probability of exploitation in the next 30 days. It does not measure your exposure or prove exploitation. The elevated threshold is 10%; CISA KEV takes precedence. About FIRST EPSS ↗

Severity and scoring

CVSS score
7.2 · HIGH
CVSS version
4.0
CVSS vector
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weaknesses
CWE-639

CVSS measures technical severity; it does not establish whether this vulnerability is being exploited in your environment.

Known exploitation and remediation

Not listed in the CISA catalog retrieved for this record. This does not establish that exploitation has not occurred.

Verify affected versions and patch availability in the vendor advisory before making changes.

Affected products and versions

  • cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:*

    Before (exclusive): 3.14.26

  • cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:*

    From (inclusive): 3.15.0

    Before (exclusive): 3.15.21

  • cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:*

    From (inclusive): 3.16.0

    Before (exclusive): 3.16.17

  • cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:*

    From (inclusive): 3.17.0

    Before (exclusive): 3.17.14

  • cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:*

    From (inclusive): 3.18.0

    Before (exclusive): 3.18.8

  • cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:*

    From (inclusive): 3.19.0

    Before (exclusive): 3.19.5

  • cpe:2.3:a:github:enterprise_server:3.20.0:*:*:*:*:*:*:*

These are NVD CPE applicability entries. Some products depend on configuration conditions; consult the official record to confirm applicability.

Advisories and references

Explore official sources

Read the official NVD record ↗

Explore the CISA catalog ↗

Back to CVE intelligence